Revision3.com Shows Schedule Inside Revision3 Store


Go Back   Revision3 Forums > Shows > Amplified

Reply
 
Thread Tools Search this Thread Display Modes

  #1  
Old 01-17-2013, 06:22 AM
samo_ak47
Newbie
 
Join Date: Jan 2013
Posts: 1
Status: Offline
Default whining and humming with new amp help!!

Hi i got some 6.5componants and 600watt 2channel amp purchases and installed at my local audio shop.

When i tested it at the shop there was a hiss and whine when the engine was on and asked the sales guy why.

The thing with my car (merc aclass) is the battery is located inside the car in the drivers footwell and they said
They couldnt do much about it.

Ive lived with the for 3 months and wanted to know if it can be sorted.

Last week i checked my pioneer deck which is suppose to be notorious for grounding issues . i did the whole rca ground thing. Didnt work so i dont think its the dec as it worked fine before i added the amp and new speakers. The rca cables were passed through close to the battery. I replaced them with high quality rca and re routed the cables. That deffinatly helped with less noise but still get alternator whine.

I changed the amp ground which was connected to the battery terminal and found another spot close to the batttery which goes to chasis. That didnt help much.

I ended up using a ground isolator connected to the amp with rca. No more whine from alternator now but theres a slight buzz when headlights are on and a really high pitch which is only noticable at low volumes or when playing songs with pauses in them. Which i find annoying.

Ive uad to turn the gain way down on the amp to get rid of most noises even with the isolator which meansni turn it way up on the deck.

I dont think i am using the amp to the fullest with this setting and i still get buzz!

I really want to get rid of the isolator and do this properly. Sorry for the ramblings but im desparate!

The amp is placed under my car seat which is very close to battery.

Thanks in advanced for any help!

Last edited by samo_ak47 : 01-17-2013 at 06:32 AM.
Reply With Quote
Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts
vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump



All times are GMT. The time now is 10:03 PM.

Rev3 Forum RSS


© 2005-2010 Revision3 Corporation